System requirements of “1C:Enterprise 8”

System requirements of 1C:Enterprise 8

Technological platform of 1C:Enterprise 8

Thin client and thick client

Operating system Note
Microsoft Windows
Windows 8
Windows 7
Windows Server 2012 (x64)
Windows Server 2008 R2 (x64)
Windows Server 2008
Windows Server 2003
Windows Server 2000
Windows Vista
Windows XP
Windows 2000
Linux
Ubuntu 12.04 LTS
Mint 12
Fedora 17

Web client

Operating system Note
Microsoft Windows
Windows 8 For computers with low memory and not powerful CPU for Internet Explorer is recommended to use version 9 or use other browsers that are supported by 1C:Enterprise
Windows 7
Windows Server 2012 (x64)
Windows Server 2008 R2 (x64)
Windows Server 2008
Windows Server 2003
Windows Server 2000
Windows Vista
Windows XP
Windows 2000
Linux
Linux
Mac OS X
Mac OS X 10.5 and later
iOS
iOS 3.2, 4.2 and later
Supported browsers Note
Mozilla Firefox from 17 for Windows and Linux
Microsoft Internet Explorer 8.0, 9.0(x86), 10(x86) for Windows

For computers with low memory and not powerful CPU for Internet Explorer is recommended to use version 9

Google Chrome 4 and later for Windows
Safari 4.0.5 and later for Mac OS X Without external components support, extension to work with files, extension to work with cryptography.

1C: Enterprise Server

x86 architecture

Operating system Note
Microsoft Windows
Windows 8
Windows 7
Windows Server 2012 (x64-bit)
Windows Server 2008
Windows Server 2003
Windows Server 2000
Windows Vista
Windows XP
Windows 2000
Linux (*)
ALT Linux 2.4 and later
only on the operational and central servers of cluster
ASP Linux 11 and later
CentOS 4 and later
Debian GNU/Linux 4.0 and later
Fedora Core 4 and later
Fedora 7 and later
Mandriva Powerpack 2009
Red Hat Enterprise Linux 4 update 4 and later
Ubuntu 7.10 and later

x86-64 architecture

Operating system Note
Microsoft Windows
Windows 8 (x64-bit)
Windows 7 (x64-bit)
Windows Server 2012 (x64-bit)
Windows Server 2008 R2 (x64-bit)
Windows Server 2008 (x64-bit)
Windows Server 2003 (x64-bit)
It is recommended to install service pack 2 (SP2)
Windows Vista (x64-bit)
Windows XP (x64-bit) It is recommended to install service pack 1 (SP1)
Linux (*)
ASP Linux 11 and later
only on the operational and central servers of cluster
CentOS 4 and later
Debian GNU/Linux 4.0 and later
Fedora Core 4 and later
Fedora 7 and later
Mandriva Powerpack 2009
Red Hat Enterprise Linux 4 update 4 and later
Ubuntu 7.10 and later

Database server
OS Series Linux and Windows are supported

x86 architecture

DBMS Note
Microsoft SQL Server
SQL Server 2012
SQL Server 2008 R2
SQL Server 2008 Need to install service pack 1 (SP1)
SQL Server 2005 Need to install service pack 3 (SP3)
SQL Server 2000
  • it is recommended to install service pack 4 (SP4)
  • need to install service pack 2 (SP2)
  • it is recommended to use SQL Server 2005 and later
PostgreSQL(*)
PostgreSQL 9.1.2

supports the following operating systems:

  • Microsoft
    • Windows 2000
    • Windows XP
    • Windows Server 2003
    • Windows 7
    • Windows Server 2008
    • Windows Server 2008 R2
  • Linux (*)
    • Fedora Core 8-15
    • Red Hat Enterprise Linux 5-6
    • Centos 5-6
    • ASP Linux 12-14
    • Ubuntu 10
    • Ubuntu 11
PostgreSQL 9.0.3

supports the following operating systems:

  • Microsoft
    • Windows 2000
    • Windows XP
    • Windows Server 2003
    • Windows 7
    • Windows Server 2008
    • Windows Server 2008 R2
  • Linux (*)
    • Fedora Core 4
    • Fedora Core 5
    • Fedora Core 6
    • Red Hat Enterprise Linux 4 update 4
    • ASP Linux 11
PostgreSQL 8.4.3
PostgreSQL 8.3.8

PostgreSQL 8.2.4

PostgreSQL 8.1.5
IBM DB2
IBM DB2 10.1
  • Express-C version supported by 1C:Enterprise is published on the IBM website
  • Supported in beta-testing mode due to the significant changes in DB2 architecture
IBM DB2 9.7 FixPack 6
  • For commercial versions of DB2 9.7 FixPak 6 is published on the IBM website
  • Express-C version supported by 1C:Enterprise is published on the customer website
IBM DB2 9.7 FixPack 1
  • Express-C version supported by 1C: Enterprise is published on the customer website
  • The list of supported operating systems is published on the IBM website
  • It is prompted to use the later versions of IBM DB2 recommended for application

IBM DB2 9.5 FixPack 4 (release 22521)

IBM DB2 9.1 (release 19840)
Oracle Database
(Standard Edition One, Standard Edition and Enterprise Edition)
Oracle Database 11gR2
  • Microsoft Windows. Version 11.2.0.3.0
  • Linux version 11.2.0.2.0 is supported in case of the following set of patches installation: 10094732, 11724916, 9620994, 10269193.
Oracle Database 11gR1 (release 11.1.0.7.0)
  • Microsoft Windows version 11.1.0.7.0 0 is supported in case of patch Bundle28 installation (patch 9707661)
  • Linux version 11.1.0.7.0 is supported in case of the following set of patches installation: 7556778, 8889930, 9038070, 9653353, 8934457
Oracle Database 10gR2 (release 10.2.0.4)
  • Microsoft Windows version 10.2.0.4 0 is supported in case of patch Bundle36 installation (patch 9544021).
  • Linux version 10.2.0.4 is supported in case of the following set of patches installation: 8576156, 9535703, 9038070, 9002115, 6642692, 8889930, 7556778, 5586604.

x86-64 architecture

DBMS Note
Microsoft SQL Server
SQL Server 2012
SQL Server 2008 R2
SQL Server 2008 Need to install service pack 1 (SP1)
SQL Server 2005 Need to install service pack 3 (SP3)
SQL Server 2000
  • it is recommended to install service pack 4 (SP4)
  • need to install service pack 2 (SP2)
  • it is recommended to use SQL Server 2005 and later
PostgreSQL(*)
PostgreSQL 9.1.2

supports the following operating systems:

  • Microsoft
    • Windows 2000
    • Windows XP
    • Windows Server 2003
    • Windows 7
    • Windows Server 2008
    • Windows Server 2008 R2
  • Linux (*)
    • Fedora Core 8-15
    • Red Hat Enterprise Linux 5-6
    • Centos 5-6
    • ASP Linux 12-14
    • Ubuntu 10
    • Ubuntu 11
PostgreSQL 9.0.3

supports the following operating systems:

  • Microsoft
    • Windows 2000
    • Windows XP
    • Windows Server 2003
    • Windows 7
    • Windows Server 2008
    • Windows Server 2008 R2
  • Linux (*)
    • Fedora Core 4
    • Fedora Core 5
    • Fedora Core 6
    • Red Hat Enterprise Linux 4 update 4
    • ASP Linux 11
PostgreSQL 8.4.3
PostgreSQL 8.3.8

PostgreSQL 8.2.4

PostgreSQL 8.1.5
IBM DB2
IBM DB2 10.1
  • Express-C version supported by 1C:Enterprise is published on the IBM website
  • Supported in beta-testing mode due to the significant changes in DB2 architecture
IBM DB2 9.7 FixPack 6
  • For commercial versions of DB2 9.7 FixPak 6 is published on the IBM website
  • Express-C version supported by 1C:Enterprise is published on the customer website
IBM DB2 9.7 FixPack 1
  • Express-C version supported by 1C: Enterprise is published on the customer website
  • The list of supported operating systems is published on the IBM website
  • It is prompted to use the later versions of IBM DB2 recommended for application

IBM DB2 9.5 FixPack 4 (release 22521)

IBM DB2 9.1 (release 19840)
Oracle Database
(Standard Edition One, Standard Edition and Enterprise Edition)
Oracle Database 11gR2
  • Microsoft Windows. Version 11.2.0.3.0
  • Linux version 11.2.0.2.0 is supported in case of the following set of patches installation: 10094732, 11724916, 9620994, 10269193.
Oracle Database 11gR1 (release 11.1.0.7.0)
  • Microsoft Windows version 11.1.0.7.0 0 is supported in case of patch Bundle28 installation (patch 9707661)
  • Linux version 11.1.0.7.0 is supported in case of the following set of patches installation: 7556778, 8889930, 9038070, 9653353, 8934457
Oracle Database 10gR2 (release 10.2.0.4)
  • Microsoft Windows version 10.2.0.4 0 is supported in case of patch Bundle36 installation (patch 9544021).
  • Linux version 10.2.0.4 is supported in case of the following set of patches installation: 8576156, 9535703, 9038070, 9002115, 6642692, 8889930, 7556778, 5586604.

IA-64 architecture

DBMS Note
Microsoft SQL Server
SQL Server 2008 R2 (64-bit) IA64
SQL Server 2008 (64-bit) IA64 need to install service pack 1 (SP1)
SQL Server 2005 (64-bit) Itanium-based need to install service pack 3 (SP3)
SQL Server 2000 (64-bit) Itanium-based
  • it is recommended to install service pack 4 (SP4)
  • need to install service pack 2 (SP2)
  • it is recommended to use SQL Server 2005 and later

Web-server

Operating system Note
Windows
IIS 5.1 IIS version supported by 1C:Enterprise is a part of Windows operating system:
  • IIS 5.1 (Windows XP Professional)
  • IIS 6.0 (Windows Server 2003)
  • IIS 7.0 (Windows Vista; Windows Server 2008)
  • IIS 7.5 (Windows 7; Windows Server 2008 R2)
  • IIS 8.0 (Windows 8; Windows Server 2012 )

Web-server IIS documentation:

Current versions of Apache web-server can be downloaded from http://httpd.apache.org/download.cgi

IIS 6.0
IIS 7.0
IIS 7.5
IIS 8.0
Apache 2.0
Apache 2.2
Linux
Apache 2.0
Apache 2.2

Mobile platform

Operating system Note
iOS
iOS 5.1
  • The only devices on the basis of ARM processors version 7 are supported
    • iPhone 3GS, 4, 4S, 5, 5S, 5C
    • iPad 1, 2, 3, 4, Air
    • iPod Touch generations 3, 4, 5
    • iPad Mini 1, 2
iOS 6.0
iOS 6.1
iOS 7.0
Android
Android 2.2–2.2.3 Froyo
  • Only supported devices based on ARM processor architecture ARMv5TE and above (ARMv6, ARMv7, ARMv8)
  • The minimal size of RAM is 256 MB
  • Touch screen
Android 2.3–2.3.7 Gingerbread
Android 3.0-3.2 Honeycomb
Android 4.0–4.0.4 Ice Cream Sandwich
Android 4.1-4.3 Jelly Bean

(*) The composition of supported distributives and installation features can be specified more exactly in the future

Leave a Reply

Your email address will not be published.

 

1C:Enterprise Developer's Community